Changeset 254aa1d in dotfiles for guix/.guix-packages/emacs.scm


Ignore:
Timestamp:
Aug 5, 2024, 6:53:43 AM (3 months ago)
Author:
Mikhail Kirillov <w96k@…>
Branches:
master
Children:
fe2941b
Parents:
7bfb563
git-author:
Mikhail Kirillov <w96k@…> (08/05/24 06:33:27)
git-committer:
Mikhail Kirillov <w96k@…> (08/05/24 06:53:43)
Message:

Massively update guix home

File:
1 edited

Legend:

Unmodified
Added
Removed
  • guix/.guix-packages/emacs.scm

    • Property mode changed from 100644 to 120000
    r7bfb563 r254aa1d  
    1 (define-module (emacs)
    2   #:use-module ((guix licenses) #:prefix license:)
    3   #:use-module (guix packages)
    4   #:use-module (guix download)
    5   #:use-module (guix build-system gnu)
    6   #:use-module (guix git-download)
    7   #:use-module (guix licenses)
    8   #:use-module (guix utils)
    9   #:use-module (guix memoization)
    10   #:use-module (guix build-system emacs)
    11   #:use-module (guix build-system glib-or-gtk)
    12   #:use-module (gnu packages)
    13   #:use-module (gnu packages imagemagick)
    14   #:use-module (gnu packages xorg)
    15   #:use-module (gnu packages base)
    16   #:use-module (gnu packages code)
    17   #:use-module (gnu packages gcc)
    18   #:use-module (gnu packages php)
    19   #:use-module (gnu packages web) 
    20   #:use-module (gnu packages autotools)
    21   #:use-module (gnu packages compression)
    22   #:use-module (gnu packages emacs)
    23   #:use-module (gnu packages emacs-xyz)
    24   #:use-module (guix utils)
    25   #:use-module (srfi srfi-1)
    26   #:use-module (ice-9 match))
    27 
    28 (define-public emacs-pythonic
    29   (package
    30    (name "emacs-pythonic")
    31    (version "0.2.0")
    32    (source (origin
    33             (method git-fetch)
    34             (uri (git-reference
    35                   (url "https://github.com/pythonic-emacs/pythonic.git")
    36                   (commit (string-append "v" version))))
    37             (file-name (git-file-name name version))
    38             (sha256
    39              (base32
    40               "0hbvy8wdi5dgxn86j8z54y2fhcvm605xxm6xv054nl6fw2hh2h5h"))))
    41    (build-system emacs-build-system)
    42    (propagated-inputs
    43     `(("s" ,emacs-s)
    44       ("f" ,emacs-f)))
    45    (home-page "https://github.com/pythonic-emacs/anaconda-mode")
    46    (synopsis "Utility functions for writing pythonic emacs package.")
    47    (description
    48     "Utility functions for writing pythonic emacs package.")
    49    (license license:gpl3+)))
    50 
    51 (define-public emacs-anaconda-mode
    52   (package
    53    (name "emacs-anaconda-mode")
    54    (version "0.1.14")
    55    (source (origin
    56             (method git-fetch)
    57             (uri (git-reference
    58                   (url "https://github.com/pythonic-emacs/anaconda-mode.git")
    59                   (commit (string-append "v" version))))
    60             (file-name (git-file-name name version))
    61             (sha256
    62              (base32
    63               "04f6kw4rd8k6waiyfbk7x8qdrqm411mdsdzjh2w9rvmv7y36ckh8"))))
    64    (build-system emacs-build-system)
    65    (propagated-inputs
    66     `(("emacs-pythonic" ,emacs-pythonic)
    67       ("dash" ,emacs-dash)
    68       ("s" ,emacs-s)
    69       ("f" ,emacs-f)))
    70    (home-page "https://github.com/pythonic-emacs/anaconda-mode")
    71    (synopsis "Code navigation, documentation lookup and completion for
    72 Python.")
    73    (description
    74     "Code navigation, documentation lookup and completion for Python.")
    75    (license license:gpl3)))
    76 
    77 (define-public emacs-kiwix
    78   (package
    79    (name "emacs-kiwix")
    80    (version "1.0.3")
    81    (source
    82     (origin
    83      (method url-fetch)
    84      (uri (string-append
    85            "https://elpa.gnu.org/packages/kiwix-"
    86            version
    87            ".tar"))
    88      (sha256
    89       (base32
    90        "061b816xp8ykqd56z0nvc69aql9y4mba42p6x6vc0j6gr9n3c1j6"))))
    91    (build-system emacs-build-system)
    92    (propagated-inputs
    93     `(("emacs-request" ,emacs-request)))
    94    (home-page
    95     "https://github.com/stardiviner/kiwix.el")
    96    (synopsis
    97     "Searching offline Wikipedia through Kiwix.")
    98    (description
    99     "Emacs client for a free offline web browser created by Emmanuel
    100 Engelhart and Renaud Gaudin in 2007.")
    101    (license license:gpl3+)))
    102 
    103 (define-public emacs-realgud-xdebug
    104   (package
    105    (name "emacs-realgud-xdebug")
    106    (version "0.1.0")
    107    (source
    108     (origin
    109      (uri (git-reference
    110            (url "https://github.com/realgud/realgud-xdebug")
    111            (commit version)))
    112      (method git-fetch)
    113      (sha256
    114       (base32 "0iyxm4yfjwpc322md8iz38xs1y6whqjgsbbs7vdjw1k5029q8nc0"))
    115      (file-name (git-file-name name version))))
    116    (build-system emacs-build-system)
    117    (inputs
    118     (list emacs-realgud))
    119    (home-page "https://github.com/realgud/realgud-xdebug/")
    120    (synopsis
    121     "Modular front-end for interacting with external debuggers")
    122    (description
    123     "RealGUD is a modular, extensible GNU Emacs front-end for interacting
    124 with external debuggers.  It integrates various debuggers such as gdb, pdb,
    125 ipdb, jdb, lldb, bashdb, zshdb, etc. and allows visually steping through code in the
    126 sources.  Unlike GUD, it also supports running multiple debug sessions in
    127 parallel.")
    128    (license license:gpl3+)))
    129 
    130 (define-public emacs-xcscope
    131     (package
    132      (name "emacs-xcscope")
    133      (version "1.5")
    134      (source (origin
    135             (method git-fetch)
    136             (uri (git-reference
    137                   (url "https://github.com/dkogan/xcscope.el")
    138                   (commit (string-append "v" version))))
    139             (file-name (git-file-name name version))
    140             (sha256
    141              (base32
    142               "0w2bxrnidladpzrd82z3w3gvjhajs71k5vjk2y03r09i9fwn2ykc"))))
    143      (build-system emacs-build-system)
    144      (home-page "https://github.com/realgud/realgud-xdebug/")
    145      (synopsis
    146       "emacs auto-complete & company-mode for php ")
    147      (description
    148       "The PHP code completion and the jump to definition/declaration/inclusion-file provided by phpctags")
    149      (license license:gpl3+)))
    150 
    151 (define-public emacs-ac-php
    152     (package
    153      (name "emacs-ac-php")
    154      (version "2.4.2")
    155      (source (origin
    156             (method git-fetch)
    157             (uri (git-reference
    158                   (url "https://github.com/xcwen/ac-php")
    159                   (commit version)))
    160             (file-name (git-file-name name version))
    161             (sha256
    162              (base32
    163               "08vfdp7q6x5fk2nn5dl884cyysxrl2gw8f16g7wqvf7v24jmx71d"))))
    164      (build-system emacs-build-system)
    165      (native-inputs
    166       (list emacs-company emacs-helm))
    167      (propagated-inputs
    168       (list emacs-php-mode php emacs-s
    169             emacs-f emacs-popup emacs-dash
    170             emacs-xcscope cscope emacs-auto-complete
    171             emacs-yasnippet))
    172      (home-page "https://github.com/xcwen/ac-php")
    173      (synopsis
    174       "emacs auto-complete & company-mode for php ")
    175      (description
    176       "The PHP code completion and the jump to definition/declaration/inclusion-file provided by phpctags")
    177      (license license:gpl3+)))
    178 
    179 (define-public emacs-php-quickhelp
    180     (package
    181      (name "emacs-php-quickhelp")
    182      (version "0.5.5")
    183      (source (origin
    184             (method git-fetch)
    185             (uri (git-reference
    186                   (url "https://github.com/vpxyz/php-quickhelp")
    187                   (commit (string-append "v" version))))
    188             (file-name (git-file-name name version))
    189             (sha256
    190              (base32
    191               "1d9rg699wl67qkb93r4qnjn0ng4xn9c2g6kc98zaiy2v0v2wcv8g"))))
    192      (build-system emacs-build-system)
    193      (propagated-inputs
    194       (list jq))
    195      (home-page "https://github.com/vpxyz/php-quickhelp")
    196      (synopsis
    197       "A php quickhelp and eldoc backed for emacs ")
    198      (description
    199       "Provide quick help (and a eldoc beckend) for company-php and company-phpactor. It require jq to extract a short help from php manual.")
    200      (license license:gpl3+)))
    201 
    202 (define-public emacs-mastodon-updated
    203   (package
    204    (inherit emacs-mastodon)
    205    (name "emacs-mastodon")
    206    (version "1.0.0")
    207    (source (origin
    208             (method git-fetch)
    209             (uri (git-reference
    210                   (url "https://codeberg.org/martianh/mastodon.el")
    211                   (commit version)))
    212             (file-name (git-file-name name version))
    213             (sha256
    214              (base32
    215               "13swcbvwhjl8ksrgzvmfafkgd3iz8znk49bs1n48w3g9qvh097w7"))))
    216    (propagated-inputs
    217     (list emacs-request))
    218    (build-system emacs-build-system)))
    219 
    220 (define-public emacs-mini-modeline
    221   (package
    222     (name "emacs-mini-modeline")
    223     (version "20211130.604")
    224     (source (origin
    225               (method git-fetch)
    226               (uri (git-reference
    227                     (url "https://github.com/kiennq/emacs-mini-modeline.git")
    228                     (commit "434b98b22c69c8b3b08e9c267c935591c49a8301")))
    229               (sha256
    230                (base32
    231                 "063bpi3gxzi6kkc3mb9h4m8lvbsvfw47z559960h912h2l3z6vhq"))))
    232     (build-system emacs-build-system)
    233     (propagated-inputs (list emacs-dash))
    234     (home-page "https://github.com/kiennq/emacs-mini-modeline")
    235     (synopsis "Display modeline in minibuffer")
    236     (description
    237      "Display modeline in minibuffer.  With this we save one display line and also
    238 don't have to see redundant information.")
    239     (license #f)))
    240 
    241 (define-public emacs-isearch-mb
    242   (package
    243     (name "emacs-isearch-mb")
    244     (version "0.5")
    245     (source (origin
    246               (method url-fetch)
    247               (uri (string-append "https://elpa.gnu.org/packages/isearch-mb-"
    248                                   version ".tar"))
    249               (sha256
    250                (base32
    251                 "0fah8dmh9jv05i93ccn9dvl7qmfy32vwxqdzkf1v8gr1plsyjyx7"))))
    252     (build-system emacs-build-system)
    253     (home-page "https://github.com/astoff/isearch-mb")
    254     (synopsis "Control isearch from the minibuffer")
    255     (description "")
    256     (license license:gpl3+)))
     1/gnu/store/bp44dky1ixj2w1hqjs8nw7a5k177vl9s-home-dotfiles--guix-packages-emacs-scm
Note: See TracChangeset for help on using the changeset viewer.