summaryrefslogtreecommitdiff
path: root/nix/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hardware-configuration.nix')
-rw-r--r--nix/hardware-configuration.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/nix/hardware-configuration.nix b/nix/hardware-configuration.nix
deleted file mode 100644
index 59157f3..0000000
--- a/nix/hardware-configuration.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-# Do not modify this file! It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations. Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
-
- boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
-
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/a1abae4a-c292-4d2c-85f8-6690bb3e4c03";
- fsType = "ext4";
- };
-
- # fileSystems."/mnt/guix" =
- # { device = "/dev/disk/by-uuid/c184f446-df67-4103-b28e-465ac8776f10";
- # fsType = "ext4";
- # };
-
- # swapDevices = [{ device = "/dev/sda1"; }];
-
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
-
- hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
- hardware.pulseaudio.enable = true;
- hardware.pulseaudio.package = pkgs.pulseaudioFull;
- hardware.opengl = {
- enable = true;
- driSupport = true;
- driSupport32Bit = true;
- extraPackages = with pkgs; [
- intel-media-driver # LIBVA_DRIVER_NAME=iHD
- vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
- vaapiVdpau
- libvdpau-va-gl
- ];
- };
-}