summaryrefslogtreecommitdiff
path: root/guix/rde/profiles.mk
diff options
context:
space:
mode:
Diffstat (limited to 'guix/rde/profiles.mk')
-rw-r--r--guix/rde/profiles.mk34
1 files changed, 0 insertions, 34 deletions
diff --git a/guix/rde/profiles.mk b/guix/rde/profiles.mk
deleted file mode 100644
index 1b90888..0000000
--- a/guix/rde/profiles.mk
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Profiles
-#
-
-# Store items doesn't have useful mtime, so we rely on guix.lock to prevent
-# unecessary rebuilds
-guix: target/guix-time-marker
-
-target/profiles:
- mkdir -p target/profiles
-
-target/guix-time-marker: rde/channels-lock.scm
- make target/profiles/guix
- touch $@
-
-target/profiles/guix: target/profiles rde/channels-lock.scm
- guix pull -C rde/channels-lock.scm -p ${GUIX_PROFILE} \
- ${PULL_EXTRA_OPTIONS}
-
-target/profiles/guix-local: target/profiles rde/channels-lock-local.scm
- guix pull -C rde/channels-lock-local.scm -p ${GUIX_PROFILE} \
- ${PULL_EXTRA_OPTIONS}
-
-rde/channels-lock.scm: rde/channels.scm
- echo -e "(use-modules (guix channels))\n" > ./rde/channels-lock-tmp.scm
- guix time-machine -C ./rde/channels.scm -- \
- describe -f channels >> ./rde/channels-lock-tmp.scm
- mv ./rde/channels-lock-tmp.scm ./rde/channels-lock.scm
-
-rde/channels-lock-local.scm: rde/channels-local.scm
- echo -e "(use-modules (guix channels))\n" > ./rde/channels-lock-tmp.scm
- guix time-machine -C ./rde/channels-local.scm -- \
- describe -f channels >> ./rde/channels-lock-tmp.scm
- mv ./rde/channels-lock-tmp.scm ./rde/channels-lock-local.scm