summaryrefslogtreecommitdiff
path: root/guix/rde/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'guix/rde/Makefile')
-rw-r--r--guix/rde/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/guix/rde/Makefile b/guix/rde/Makefile
deleted file mode 100644
index f829718..0000000
--- a/guix/rde/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# profiles.mk provides guix version specified by rde/channels-lock.scm
-# To rebuild channels-lock.scm use `make -B rde/channels-lock.scm`
-include profiles.mk
-
-# Also defined in .envrc to make proper guix version available project-wide
-GUIX_PROFILE=target/profiles/guix
-GUIX=./pre-inst-env ${GUIX_PROFILE}/bin/guix
-
-SRC_DIR=./src
-CONFIGS=${SRC_DIR}/abcdw/configs.scm
-PULL_EXTRA_OPTIONS=
-# --allow-downgrades
-
-ROOT_MOUNT_POINT=/mnt
-
-VERSION=latest
-
-target:
- mkdir -p target
-
-build-home: guix
- ${GUIX} home build ./src/wkz-p1.scm
-
-install-home: guix
- ${GUIX} home reconfigure ./src/wkz-p1.scm -v 5
-
-rollback-home: guix
- ${GUIX} home roll-back
-
-clean-target:
- rm -rf ./target
-
-clean: clean-target