1 | # Do not modify this file! It was generated by ‘nixos-generate-config’
|
---|
2 | # and may be overwritten by future invocations. Please make changes
|
---|
3 | # to /etc/nixos/configuration.nix instead.
|
---|
4 | { config, lib, pkgs, modulesPath, ... }:
|
---|
5 |
|
---|
6 | {
|
---|
7 | imports =
|
---|
8 | [ (modulesPath + "/installer/scan/not-detected.nix")
|
---|
9 | ];
|
---|
10 |
|
---|
11 | boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
|
---|
12 | boot.initrd.kernelModules = [ ];
|
---|
13 | boot.kernelModules = [ "kvm-intel" ];
|
---|
14 | boot.extraModulePackages = [ ];
|
---|
15 |
|
---|
16 | fileSystems."/" =
|
---|
17 | { device = "/dev/disk/by-uuid/a1abae4a-c292-4d2c-85f8-6690bb3e4c03";
|
---|
18 | fsType = "ext4";
|
---|
19 | };
|
---|
20 |
|
---|
21 | # fileSystems."/mnt/guix" =
|
---|
22 | # { device = "/dev/disk/by-uuid/c184f446-df67-4103-b28e-465ac8776f10";
|
---|
23 | # fsType = "ext4";
|
---|
24 | # };
|
---|
25 |
|
---|
26 | # swapDevices = [{ device = "/dev/sda1"; }];
|
---|
27 |
|
---|
28 | # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
---|
29 | # (the default) this is the recommended approach. When using systemd-networkd it's
|
---|
30 | # still possible to use this option, but it's recommended to use it in conjunction
|
---|
31 | # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
---|
32 | networking.useDHCP = lib.mkDefault true;
|
---|
33 | # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
|
---|
34 | # networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
|
---|
35 |
|
---|
36 | hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
---|
37 | hardware.pulseaudio.enable = true;
|
---|
38 | hardware.pulseaudio.package = pkgs.pulseaudioFull;
|
---|
39 | hardware.opengl = {
|
---|
40 | enable = true;
|
---|
41 | driSupport = true;
|
---|
42 | driSupport32Bit = true;
|
---|
43 | extraPackages = with pkgs; [
|
---|
44 | intel-media-driver # LIBVA_DRIVER_NAME=iHD
|
---|
45 | vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
|
---|
46 | vaapiVdpau
|
---|
47 | libvdpau-va-gl
|
---|
48 | ];
|
---|
49 | };
|
---|
50 | }
|
---|