source: dotfiles/guix/.guix-packages/php.scm@ 5516569

Last change on this file since 5516569 was 5516569, checked in by Mikhail Kirillov <w96k@…>, on Oct 6, 2022 at 12:26:10 PM

Add changes to config

  • Property mode set to 100644
File size: 20.9 KB
RevLine 
[1e08614]1(define-module (php)
2 #:use-module (gnu packages php)
3 #:use-module (gnu packages)
4 #:use-module (gnu packages algebra)
5 #:use-module (gnu packages aspell)
6 #:use-module (gnu packages base)
7 #:use-module (gnu packages bison)
8 #:use-module (gnu packages compression)
9 #:use-module (gnu packages crypto)
10 #:use-module (gnu packages curl)
11 #:use-module (gnu packages cyrus-sasl)
12 #:use-module (gnu packages databases)
13 #:use-module (gnu packages dbm)
14 #:use-module (gnu packages fontutils)
15 #:use-module (gnu packages gd)
16 #:use-module (gnu packages gettext)
17 #:use-module (gnu packages gnupg)
18 #:use-module (gnu packages icu4c)
19 #:use-module (gnu packages image)
20 #:use-module (gnu packages linux)
21 #:use-module (gnu packages multiprecision)
22 #:use-module (gnu packages openldap)
23 #:use-module (gnu packages pcre)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages readline)
26 #:use-module (gnu packages sqlite)
27 #:use-module (gnu packages textutils)
28 #:use-module (gnu packages tls)
29 #:use-module (gnu packages web)
30 #:use-module (gnu packages xml)
31 #:use-module (gnu packages xorg)
32 #:use-module (guix packages)
33 #:use-module (guix download)
34 #:use-module (guix build-system gnu)
35 #:use-module (guix utils)
36 #:use-module ((guix licenses) #:prefix license:))
37
[5516569]38;; (define-public php-8
39;; (package
40;; (name "php-8")
41;; (version "8.1.9")
42;; (home-page "https://secure.php.net/")
43;; (source (origin
44;; (method url-fetch)
45;; (uri (string-append home-page "distributions/"
46;; "php-" version ".tar.xz"))
47;; (sha256
48;; (base32
49;; "1gr79i9dwm7qiqgimxms8rlvzzazh66sa4w9nr1cjk95wrrpwisk"))
50;; (modules '((guix build utils)))
51;; (snippet
52;; '(with-directory-excursion "ext"
53;; (for-each delete-file-recursively
54;; ;; Some of the bundled libraries have no proper upstream.
55;; ;; Ideally we'd extract these out as separate packages:
56;; ;;"mbstring/libmbfl"
57;; ;;"date/lib"
58;; ;;"bcmath/libbcmath"
59;; ;;"fileinfo/libmagic" ; a patched version of libmagic
60;; '("gd/libgd"
61;; "pcre/pcre2lib"
62;; "xmlrpc/libxmlrpc"))))))
63;; (build-system gnu-build-system)
64;; (arguments
65;; `(#:configure-flags
66;; (let-syntax ((with (syntax-rules ()
67;; ((_ option input)
68;; (string-append option "="
69;; (assoc-ref %build-inputs input))))))
70;; (list (with "--with-bz2" "bzip2")
71;; (with "--with-curl" "curl")
72;; (with "--with-gdbm" "gdbm")
73;; (with "--with-gettext" "libc") ; libintl.h
74;; (with "--with-gmp" "gmp")
75;; (with "--with-ldap" "openldap")
76;; (with "--with-ldap-sasl" "cyrus-sasl")
77;; (with "--with-pdo-pgsql" "postgresql")
78;; (with "--with-pdo-sqlite" "sqlite")
79;; (with "--with-pgsql" "postgresql")
80;; ;; PHP’s Pspell extension, while retaining its current name,
81;; ;; now uses the Aspell library.
82;; (with "--with-pspell" "aspell")
83;; (with "--with-readline" "readline")
84;; (with "--with-sodium" "libsodium")
85;; (with "--with-sqlite3" "sqlite")
86;; (with "--with-tidy" "tidy")
87;; (with "--with-xsl" "libxslt")
88;; (with "--with-zlib-dir" "zlib")
89;; ;; We could add "--with-snmp", but it requires netsnmp that
90;; ;; we don't have a package for. It is used to build the snmp
91;; ;; extension of php.
92;; "--with-external-pcre"
93;; "--with-external-gd"
94;; "--with-iconv"
95;; "--with-openssl"
96;; "--with-mysqli" ; Required for, e.g. wordpress
97;; "--with-pdo-mysql"
98;; "--with-zip"
99;; "--with-zlib"
100;; "--enable-bcmath" ; Required for, e.g. Zabbix frontend
101;; "--enable-calendar"
102;; "--enable-dba=shared"
103;; "--enable-exif"
104;; "--enable-flatfile"
105;; "--enable-fpm"
106;; "--enable-ftp"
107;; "--enable-gd"
108;; "--enable-inifile"
109;; "--enable-intl"
110;; "--enable-mbstring"
111;; "--enable-pcntl"
112;; "--enable-sockets"))
113;; #:phases
114;; (modify-phases %standard-phases
115;; (add-after 'unpack 'do-not-record-build-flags
116;; (lambda _
117;; ;; Prevent configure flags from being stored and causing
118;; ;; unnecessary runtime dependencies.
119;; (substitute* "scripts/php-config.in"
120;; (("@CONFIGURE_OPTIONS@") "")
121;; (("@PHP_LDFLAGS@") ""))
122;; ;; This file has ISO-8859-1 encoding.
123;; (with-fluids ((%default-port-encoding "ISO-8859-1"))
124;; (substitute* "main/build-defs.h.in"
125;; (("@CONFIGURE_COMMAND@") "(omitted)")))))
126;; (add-before 'build 'patch-/bin/sh
127;; (lambda _
128;; (substitute* '("run-tests.php" "ext/standard/proc_open.c")
129;; (("/bin/sh") (which "sh")))))
130;; (add-before 'check 'prepare-tests
131;; (lambda _
132;; ;; Some of these files have ISO-8859-1 encoding, whereas others
133;; ;; use ASCII, so we can't use a "catch-all" find-files here.
134;; (with-fluids ((%default-port-encoding "ISO-8859-1"))
135;; (substitute* '("ext/mbstring/tests/mb_send_mail02.phpt"
136;; "ext/mbstring/tests/mb_send_mail04.phpt"
137;; "ext/mbstring/tests/mb_send_mail05.phpt"
138;; "ext/mbstring/tests/mb_send_mail06.phpt")
139;; (("/bin/cat") (which "cat"))))
140;; (substitute* '("ext/mbstring/tests/mb_send_mail01.phpt"
141;; "ext/mbstring/tests/mb_send_mail03.phpt"
142;; "ext/mbstring/tests/bug52681.phpt"
143;; "ext/standard/tests/general_functions/bug34794.phpt"
144;; "ext/standard/tests/general_functions/bug44667.phpt"
145;; "ext/standard/tests/general_functions/proc_open.phpt")
146;; (("/bin/cat") (which "cat")))
[1e08614]147
[5516569]148;; ;; The encoding of this file is not recognized, so we simply drop it.
149;; (delete-file "ext/mbstring/tests/mb_send_mail07.phpt")
[1e08614]150
[5516569]151;; (substitute* "ext/standard/tests/streams/bug60602.phpt"
152;; (("'ls'") (string-append "'" (which "ls") "'")))
[1e08614]153
[5516569]154;; ,@(if (string-prefix? "arm" (or (%current-system)
155;; (%current-target-system)))
156;; ;; Drop tests known to fail on armhf.
157;; '((for-each delete-file
158;; (list
159;; "ext/calendar/tests/unixtojd_error1.phpt"
160;; ;; arm can be a lot slower, so a time-related test fails
161;; "ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
162;; "ext/pcntl/tests/pcntl_unshare_01.phpt"
163;; "ext/pcre/tests/bug76514.phpt"
164;; "ext/pcre/tests/preg_match_error3.phpt"
165;; "ext/pcre/tests/cache_limit.phpt"
166;; "ext/sockets/tests/socket_getopt.phpt"
167;; "ext/sockets/tests/socket_sendrecvmsg_error.phpt"
168;; "ext/standard/tests/general_functions/var_export-locale.phpt"
169;; "ext/standard/tests/general_functions/var_export_basic1.phpt"
170;; "ext/intl/tests/timezone_getErrorCodeMessage_basic.phpt"
171;; "ext/intl/tests/timezone_getOffset_error.phpt"
172;; "sapi/cli/tests/cli_process_title_unix.phpt"
173;; "sapi/cli/tests/upload_2G.phpt"
174;; "Zend/tests/concat_003.phpt")))
175;; '())
[1e08614]176
[5516569]177;; ,@(if (target-ppc64le?)
178;; ;; Drop tests known to fail on powerpc64le.
179;; '((for-each delete-file
180;; (list
181;; ;; phpdbg watchpoints don't work.
182;; ;; Bug tracked upstream at:
183;; ;; https://bugs.php.net/bug.php?id=81408
184;; "sapi/phpdbg/tests/watch_001.phpt"
185;; "sapi/phpdbg/tests/watch_003.phpt"
186;; "sapi/phpdbg/tests/watch_004.phpt"
187;; "sapi/phpdbg/tests/watch_005.phpt"
188;; "sapi/phpdbg/tests/watch_006.phpt")))
189;; '())
[1e08614]190
[5516569]191;; ;; Drop tests that are known to fail.
192;; (for-each delete-file
193;; '("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
194;; "ext/posix/tests/posix_getgrnam_basic.phpt" ; Requires /etc/group.
195;; "ext/sockets/tests/bug63000.phpt" ; Fails to detect OS.
196;; "ext/sockets/tests/socket_shutdown.phpt" ; Requires DNS.
197;; "ext/sockets/tests/socket_send.phpt" ; Likewise.
198;; "ext/sockets/tests/mcast_ipv4_recv.phpt" ; Requires multicast.
199;; ;; These needs /etc/services.
200;; "ext/standard/tests/general_functions/getservbyname_basic.phpt"
201;; "ext/standard/tests/general_functions/getservbyport_basic.phpt"
202;; "ext/standard/tests/general_functions/getservbyport_variation1.phpt"
203;; ;; And /etc/protocols.
204;; "ext/standard/tests/network/getprotobyname_basic.phpt"
205;; "ext/standard/tests/network/getprotobynumber_basic.phpt"
206;; ;; And exotic locales.
207;; "ext/standard/tests/strings/setlocale_basic1.phpt"
208;; "ext/standard/tests/strings/setlocale_basic2.phpt"
209;; "ext/standard/tests/strings/setlocale_basic3.phpt"
210;; "ext/standard/tests/strings/setlocale_variation1.phpt"
211;; ;; This failing test is skipped on PHP's Travis CI as it is
212;; ;; supposedly inaccurate.
213;; "ext/standard/tests/file/disk_free_space_basic.phpt"
214;; ;; The following test erroneously expect the link
215;; ;; count of a sub-directory to increase compared to
216;; ;; its parent.
217;; "ext/standard/tests/file/lstat_stat_variation8.phpt"
218;; ;; This tests whether microseconds ‘differ enough’ and
219;; ;; fails inconsistently on ‘fast’ machines.
220;; "ext/date/tests/bug73837.phpt"
[1e08614]221
[5516569]222;; ;; XXX: These gd tests fails. Likely because our version
223;; ;; is different from the (patched) bundled one.
224;; ;; Here, gd quits immediately after "fatal libpng error"; while the
225;; ;; test expects it to additionally return a "setjmp" error and warning.
226;; "ext/gd/tests/bug39780_extern.phpt"
227;; "ext/gd/tests/libgd00086_extern.phpt"
228;; ;; Extra newline in gd-png output.
229;; "ext/gd/tests/bug45799.phpt"
230;; ;; Test expects generic "gd warning" but gets the actual function name.
231;; "ext/gd/tests/createfromwbmp2_extern.phpt"
232;; ;; This bug should have been fixed in gd 2.2.2.
233;; ;; Is it a regression?
234;; "ext/gd/tests/bug65148.phpt"
235;; ;; This bug should have been fixed in the gd 2.2
236;; ;; series. Perhaps a regression introduced by gd
237;; ;; 2.3.0?
238;; "ext/gd/tests/bug66590.phpt"
239;; ;; This bug should have been fixed in the php-5.5
240;; ;; series. Perhaps a regression introduced by gd
241;; ;; 2.3.0?
242;; "ext/gd/tests/bug70102.phpt"
243;; ;; This bug should have been fixed in the php-5.6
244;; ;; series. Perhaps a regression introduced by gd
245;; ;; 2.3.0?
246;; "ext/gd/tests/bug73869.phpt"
247;; ;; Some WebP related tests fail.
248;; "ext/gd/tests/webp_basic.phpt"
249;; "ext/gd/tests/imagecreatefromstring_webp.phpt"
250;; ;; Expected error message, but from the wrong function
251;; "ext/gd/tests/bug77269.phpt"
252;; ;; TODO: Enable these when libgd is built with xpm support.
253;; "ext/gd/tests/xpm2gd.phpt"
254;; "ext/gd/tests/xpm2jpg.phpt"
255;; "ext/gd/tests/xpm2png.phpt"
256;; ;; Whitespace difference, probably caused by a very
257;; ;; long store path
258;; "ext/gd/tests/bug77479.phpt"
259;; ;; Expected invalid XBM but got EOF before image was
260;; ;; complete. It's a warning in both cases and test
261;; ;; result is the same.
262;; "ext/gd/tests/bug77973.phpt"
263;; ;; Test expects uninitialized value to be false, but
264;; ;; instead gets "resource(5) of type (gd)".
265;; "ext/gd/tests/bug79067.phpt"
266;; ;; The following test fails with "The image size
267;; ;; differs: expected 114x115, got 117x117".
268;; "ext/gd/tests/bug79068.phpt"
[1e08614]269
[5516569]270;; ;; XXX: These iconv tests have the expected outcome,
271;; ;; but with different error messages.
272;; ;; Expects "illegal character", instead gets "unknown error (84)".
273;; "ext/iconv/tests/bug52211.phpt"
274;; "ext/iconv/tests/bug60494.phpt"
275;; ;; Expects "wrong charset", gets unknown error (22).
276;; "ext/iconv/tests/iconv_strlen_error2.phpt"
277;; "ext/iconv/tests/iconv_substr_error2.phpt"
278;; ;; Expects conversion error, gets "error condition Termsig=11".
279;; "ext/iconv/tests/iconv_strpos_error2.phpt"
280;; "ext/iconv/tests/iconv_strrpos_error2.phpt"
281;; ;; Expects "invalid multibyte sequence" but got
282;; ;; "unknown error".
283;; "ext/iconv/tests/bug76249.phpt"
[1e08614]284
[5516569]285;; ;; XXX: These test failures appear legitimate, needs investigation.
286;; ;; open_basedir() restriction failure.
287;; "ext/curl/tests/bug61948-unix.phpt"
288;; ;; Expects a false boolean, gets empty array from glob().
289;; "ext/standard/tests/file/bug41655_1.phpt"
290;; "ext/standard/tests/file/glob_variation5.phpt"
291;; ;; The test expects an Array, but instead get the contents(?).
292;; "ext/gd/tests/bug43073.phpt"
293;; ;; imagettftext() returns wrong coordinates.
294;; "ext/gd/tests/bug48732-mb.phpt"
295;; "ext/gd/tests/bug48732.phpt"
296;; ;; Similarly for imageftbbox().
297;; "ext/gd/tests/bug48801-mb.phpt"
298;; "ext/gd/tests/bug48801.phpt"
299;; ;; Different expected output from imagecolorallocate().
300;; "ext/gd/tests/bug53504.phpt"
301;; ;; Wrong image size after scaling an image.
302;; "ext/gd/tests/bug73272.phpt"
303;; ;; Expects iconv to detect illegal characters, instead gets
304;; ;; "unknown error (84)" and heap corruption(!).
305;; "ext/iconv/tests/bug48147.phpt"
306;; ;; Expects illegal character ".", gets "=?utf-8?Q?."
307;; "ext/iconv/tests/bug51250.phpt"
308;; ;; iconv throws "buffer length exceeded" on some string checks.
309;; "ext/iconv/tests/iconv_mime_encode.phpt"
310;; ;; file_get_contents(): iconv stream filter
311;; ;; ("ISO-8859-1"=>"UTF-8") unknown error.
312;; "ext/standard/tests/file/bug43008.phpt"
313;; ;; Table data not created in sqlite(?).
314;; "ext/pdo_sqlite/tests/bug_42589.phpt"
315;; ;; Expects an Array with 3 preg_matches; gets 0.
316;; "ext/pcre/tests/bug79846.phpt"
317;; ;; Expects an empty Array; gets one with " " in it.
318;; "ext/pcre/tests/bug80118.phpt"
319;; ;; Renicing a process fails in the build environment.
320;; "ext/standard/tests/general_functions/proc_nice_basic.phpt"
321;; ;; Can fail on fast machines?
322;; "Zend/tests/bug74093.phpt"))
[1e08614]323
[5516569]324;; ;; Accomodate two extra openssl errors flanking the expected one:
325;; ;; random number generator:RAND_{load,write}_file:Cannot open file
326;; ;; This is due to an invalid $HOME, but changing it in the test
327;; ;; still prints the first one & changing it globally is overkill.
328;; (substitute* "ext/openssl/tests/bug80747.phpt"
329;; ((".*error:%s:key size too small.*" match)
330;; (string-append "%s\n" match "%s\n")))
[1e08614]331
[5516569]332;; ;; Skip tests requiring network access.
333;; (setenv "SKIP_ONLINE_TESTS" "1")
334;; ;; Without this variable, 'make test' passes regardless of failures.
335;; (setenv "REPORT_EXIT_STATUS" "1")
336;; ;; Skip tests requiring I/O facilities that are unavailable in the
337;; ;; build environment
338;; (setenv "SKIP_IO_CAPTURE_TESTS" "1"))))
339;; #:test-target "test"))
340;; (inputs
341;; `(("aspell" ,aspell)
342;; ("bzip2" ,bzip2)
343;; ("curl" ,curl)
344;; ("cyrus-sasl" ,cyrus-sasl)
345;; ("gd" ,gd)
346;; ("gdbm" ,gdbm)
347;; ("gmp" ,gmp)
348;; ("gnutls" ,gnutls)
349;; ("icu4c" ,icu4c)
350;; ("libgcrypt" ,libgcrypt)
351;; ("libpng" ,libpng)
352;; ("libsodium" ,libsodium)
353;; ("libxml2" ,libxml2)
354;; ("libxslt" ,libxslt)
355;; ("libx11" ,libx11)
356;; ("libzip" ,libzip)
357;; ("oniguruma" ,oniguruma)
358;; ("openldap" ,openldap)
359;; ("openssl" ,openssl)
360;; ("pcre" ,pcre2)
361;; ("postgresql" ,postgresql)
362;; ("readline" ,readline)
363;; ("sqlite" ,sqlite)
364;; ("tidy" ,tidy)
365;; ("zlib" ,zlib)))
366;; (native-inputs
367;; `(("pkg-config" ,pkg-config)
368;; ("bison" ,bison)
369;; ("gettext" ,gettext-minimal)
370;; ("procps" ,procps))) ; for tests
371;; (synopsis "PHP programming language")
372;; (description
373;; "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
374;; language designed primarily for web development but is also used as
375;; a general-purpose programming language. PHP code may be embedded into
376;; HTML code, or it can be used in combination with various web template
377;; systems, web content management systems and web frameworks." )
378;; (license (list
379;; (license:non-copyleft "file://LICENSE") ; The PHP license.
380;; (license:non-copyleft "file://Zend/LICENSE") ; The Zend license.
381;; license:lgpl2.1 ; ext/mbstring/libmbfl
382;; license:lgpl2.1+ ; ext/bcmath/libbcmath
383;; license:bsd-2 ; ext/fileinfo/libmagic
384;; license:expat))))
Note: See TracBrowser for help on using the repository browser.